toggle menu

[Android] minSdkVersion, targetSdkVersion, Project build target

2013.05.23 17:56 Android
안드로이드 개발을 하다보면, 일단 어느 OS를 기준으로 개발해야겠다고 생각은 하지만, 막상 어느 설정을 건드려야 이 최소 OS를 설정해서 개발할 수 있는지 헷갈릴 때가 많다.

안드로이드 개발에서 OS 버전과 관련된 설정 항목들은 아래 세가지 정도이다.


minSdkVersion
어플리케이션이 동작가능한 최소의 API 레벨

targetSdkVersion
선언하지 않는 경우 기본값으로 minSdkVersion의 값이 선언

Project build target
target OS 버전은 그냥 컴파일에 사용할 SDK 버전 


이 중에서 minSdkVersion 이 바로 최소한 이 버전의 OS가 깔린 기기에서 실행되도록 하겠다는 기준을 설정하는 옵션이다.

그 다음 targetSdkVersion은 다소 애매한데, 타켓이 되는 OS는 이 버전이고 이 타켓 OS 버전 이상일 경우 특정 기능이 활성화되거나 하는 식이다. (홀로 테마 같은?)

마지막 옵션은 개발 소스를 빌드할 때 어느 OS 로 컴파일할지에 대한 것이다. 설명이 조금 애매한데, minSdkVersion보다 높아도 괜찮은 것 같다. 


 
신고

Android 관련 포스팅 더보기